Jump to content
Eternal

Quests limit is too low.

Recommended Posts

Brief Context

The behaviour of stacking some quests to be completed because the place that the npc to complete them is kinda far, is normal for the player to just wait before going to complete it and first complete other quests in the way and get some new ones in the process, then going for the further one to deliver it and this way optimize your time. That is very natural.

The Problem

But well, when you have a 10 quests limit you just cannot do this sometimes, I ran into this problem often times when I was playing yesterday, and then I was unable to get more quests and needed to walk great distances without needing just to complete quests before. And i found it a very bad experience.

I don't see a good point for limiting the active quests to 10. But I clearly see a bad point of doing that.

Solution

Raising the quests limit to something like 20 or more.

Another way to get rid of this problem is to have an option to disable some quests temporarily so you can accept the other ones and only the active number that limits to 10.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...